SmartMiner EOL, Author call switching to EWBF miner

#1

SmartMiner was running aion mainnet for 3 month till now , free of charge and forged 700K blocks.
Now this miner finally can move into end of life phase, there are no new dev plan, not open for bug tickets , the binary download link will also be removed.

SmartMiner encourage every community member switching to new EWBF miner, which is a commercial miner with 2% devs fees and also with professional support.

As a developer, I know it’s a pretty challenge job to write a aion miner correctly not even mention deep optimisation. Thanks for EWBF miner ( and also the Bminer soon) 's effort , and please support them with the passion of aion community.

For the current smartminer user, if there was no issue for your rig ( means you happy with it ), and you are not willing switching to new one , my word is it can running forever with correct functionality and no charge.

Smartbitcoin , July 18, 2018.

19 Likes
#2

Thanks for all your efforts, wish I had the skills to create a miner like that! You did a great job.

1 Like
pinned globally #3
#4

Thank you for everything that you have contributed to our community! You rock!

#5

Thank you, man! Great job!

#6

smartbitcoin is a true gentleman, and a scholar.

Forging 700k blocks is no mean feat.

I’m still running smart miner until I can figure out EWBF.

#7

It’s great what you did. I’m sure you could have made us a great windows miner too :kissing_heart:

I wish you the best for your next projects. I will follow your github from time to time to see what you are working on :blush:

#8

thank you for your work!

#9

Thanks!!! Been running smart miner on Ubuntu since the begining with no issues, don’t plan on changing over

#10

It takes seconds to change… And you make 10 to 20% more sol/s… Even the author tells to change. I liked my smartminer but there is no reason not to change… Even if in love with smartminer :heart_eyes:

1 Like
#11

I have been unable to get EWBF v0.5 to work. I have attempted to configure with both solo and public pools however keep getting incorrect work errors.

Has anyone else experienced this? Solutions?

#12

Can you be a little more descriptive please? What operating system are you using? What drivers? Which GPUs are you using? What is your miner command syntax?

#13

Hey Yashnik, thanks for following up… heres my info.
I’ve also tried running a solo node and I get the same error.
It works with SmartMiner tho…

Ubuntu 17.10
I’ve got a mix of 1070s and 1050s

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104 [10de:1b82] (rev a1)
Subsystem: ASUSTeK Computer Inc. GP104 [1043:861e]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_396, nvidia_396_drm

06:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82] (rev a1)
Subsystem: ZOTAC International (MCO) Ltd. GP107 [GeForce GTX 1050 Ti] [19da:1454]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_396, nvidia_396_drm

-------> miner.cfg <-------

Common parameters

All the parameters here are similar to the command line arguments

[common]
cuda_devices 0 1 2 3 4 5 6 7 8 9 10 11 12
templimit 80
pec 0
boff 0
eexit 0
tempunits C
log 3
logfile log_name.log
algo aion
pers ZERO_PoW

The miner start work from this server

When the server is fail, the miner will try to reconnect 3 times

After three unsuccessful attempts, the miner will switch to the next server

You can add up to 8 servers

main server

[server]
server aion-us.luxor.tech
port 3366
user 0xa********** :slight_smile: *************
pass x

./miner
±------------------------------------------------+
| EWBF’s Eqihash CUDA miner. v0.5 |
±------------------------------------------------+
22:39:58 INFO: Used config file: miner.cfg
22:39:58 INFO: Configured pools: 2
22:39:58 INFO: Selected pool: aion-us.luxor.tech:3366
22:39:58 INFO: Algorithm: 210_9 “ZERO_PoW”
22:39:58 INFO: Devices: User defined.
22:39:58 INFO: Temperature limit: 80
22:39:58 INFO: Api: Disabled

22:39:58 INFO: Target: 0003ffffffffffff…
22:39:58 INFO: Received incorrect work!
22:39:59 CUDA: Device: 0 GeForce GTX 1070 Ti, 8119 MB i:64
22:39:59 CUDA: Device: 1 GeForce GTX 1070 Ti, 8119 MB i:64
22:39:59 CUDA: Device: 2 GeForce GTX 1070 Ti, 8119 MB i:64
22:39:59 CUDA: Device: 3 GeForce GTX 1070 Ti, 8119 MB i:64
22:39:59 CUDA: Device: 4 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 5 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 6 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 7 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 8 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 9 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 10 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 11 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 CUDA: Device: 12 GeForce GTX 1050 Ti, 4040 MB i:64
22:39:59 INFO: Received incorrect work!

#14

Have you tried running the miner using the command line and not the config file?

#15

You have incorrect pers value: pers ZERO_PoW

You can remove this line altogether or specify it correctly: pers AION0PoW

Please see: EWBF Aion Miner Released

1 Like
#16

Nice! Thanks, I missed that.